分类 网络工程 下的文章

应基友要求写一遍安装EasyXSS 1.0的文章,就在windows临时搭建了一下XSS环境,使用的是XAMPP搭建的,比较方便。
XAMPP截图
11-150x150
1.apache 配置要点

DocumentRoot “D:/xampp/htdocs”

2.解压EASYXSS为xss到web目录下

修改配置文件D:xampphtdocsxssAppConfconfig.php
 'User',
        'URL_MODEL'          => '1',
        'SESSION_AUTO_START' => true,
        'DB_DSN' => 'mysql://root:@127.0.0.1:3306/xss_tw',
        'DB_PREFIX' => 'xss_',
        'MAIL_ADDRESS'=>'info@xss.tw',
        'MAIL_SMTP'=>'smtp.gmail.com',
        'MAIL_LOGINNAME'=>'info@xss.tw',
        'MAIL_PASSWORD'=>'',
        'MAIL_SENDER'=>'info',
        'MAIL_PORT'=>'465',
        'TMPL_PARSE_STRING' =>array(
        	'__SITENAME__' =>'EasyXSS 1.0',
        	'__SITETITLE__'=>'EasyXSS',
        	),
    );
?>

root为用户名,密码为空
3.创建数据库

mysql> show databases;
+--------------------+
| Database           |
+--------------------+
| information_schema |
| cdcol              |
| mysql              |
| performance_schema |
| phpmyadmin         |
| webauth            |
+--------------------+
6 rows in set (0.00 sec)
mysql> create database xss_tw;
Query OK, 1 row affected (0.00 sec)
mysql> show databases;
+--------------------+
| Database           |
+--------------------+
| information_schema |
| cdcol              |
| mysql              |
| performance_schema |
| phpmyadmin         |
| webauth            |
| xss_tw             |
+--------------------+
7 rows in set (0.00 sec)
D:xamppmysqlbin>mysql.exe -uroot xss_tw -p < data.sql
Enter password:
D:xamppmysqlbin>mysql.exe -uroot -p
Enter password:
Welcome to the MySQL monitor.  Commands end with ; or g.
Your MySQL connection id is 5
Server version: 5.5.8 MySQL Community Server (GPL)
Copyright (c) 2000, 2010, Oracle and/or its affiliates. All rights reserved.
Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.
Type 'help;' or 'h' for help. Type 'c' to clear the current input statement.
mysql> use xss_tw
Database changed
mysql> show tables;
+------------------+
| Tables_in_xss_tw |
+------------------+
| xss_ipdata       |
| xss_key          |
| xss_keyemail     |
| xss_project      |
| xss_user         |
| xss_xssresult    |
+------------------+
6 rows in set (0.00 sec)
mysql> select * from xss_key
    -> ;
+-----+-------+------------+-------+------+
| iid | ctime | key        | utime | user |
+-----+-------+------------+-------+------+
|   1 |     0 | 1234567890 |     0 |      |
+-----+-------+------------+-------+------+
1 row in set (0.02 sec)

4.注册用户
22-150x150
5.登录
33-150x150
6.测试
44-150x150

今天回家网络出问题了,播不号了,pppoe一直连接着。感觉网线坏了或者对端交换机口DOWN了,于是叫小区宽带工作人员看看。他大爷的让我重起计算机,哥以前也是学网络的啊,重启管毛,忽悠哥阿。于是把他给弄到家来了,让他看看。他连接也不行,最后修改了一下网卡属性,为10M半双工,我晕好了,好尴尬阿。他走了,百度之,原来是线有问题了,安'普的破线,假的吧。应该是8根线坏了几根,搞的全双工不行了,只能半双工了。速度肯定不行阿,这个问题感觉应该也是自动协商的BUG把,没有初始化一下吗。废话不多说,看下面的吧。



全双工与半双工的区别 网线水晶头 排线顺序

全双工传输

英文写法是:Full-Duplex Transmissions

是指交换机在发送数据的同时也能够接收数据,两者同步进行,这好像我们平时打电话一样,说话的同时也能够听到对方的声音。目前的交换机都支持全双工。

全双工的好处在于迟延小,速度快。

与之对应的是【半双工】这个概念:就是指一个时间段内只有一个动作发生,举个简单例子,一天窄窄的马路,同时只能有一辆车通过,当目前有两量车对开,这种情况下就只能一辆先过,等到头儿后另一辆再开,这个例子就形象的说明了半双工的原理。早期的对讲机、以及早期集线器等设备都是实行半双工的产品。随着技术的不断进步,半双工会逐渐退出历史舞台。

全双工与半双工

   在串行通信中,数据通常是在两个站(如终端和微机)之间进行传送,按照数据流的方向可分成三种基本的传送方式:全双工、半双工、和单工.但单工目前已很少采用,下面仅介绍前两种方式. 

1 、全双工方式( full duplex )
   当数据的发送和接收分流,分别由两根不同的传输线传送时,通信双方都能在同一时刻进行发送和接收操作,这样的传送方式就是全双工制.在全双工方式下,通信系统的每一端都设置了发送器和接收器,因此,能控制数据同时在两个方向上传送.全双工方式无需进行方向的切换,因此,没有切换操作所产生的时间延迟,这对那些不能有时间延误的交互式应用(例如远程监测和控制系统)十分有利.这种方式要求通讯双方均有发送器和接收器,同时,需要 2 根数据线传送数据信号.(可能还需要控制线和状态线,以及地线). 

   比如,计算机主机用串行接口连接显示终端,而显示终端带有键盘.这样,一方面键盘上输入的字符送到主机内存;另一方面,主机内存的信息可以送到屏幕显示.通常,往键盘上打入 1 个字符以后,先不显示,计算机主机收到字符后,立即回送到终端,然后终端再把这个字符显示出来.这样,前一个字符的回送过程和后一个字符的输入过程是同时进行的,即工作于全双工方式. 

2 、半双式方式( half duplex ) 
   若使用同一根传输线既作接收又作发送,虽然数据可以在两个方向上传送,但通信双方不能同时收发数据,这样的传送方式就是半双工制.采用半双工方式时,通信系统每一端的发送器和接收器,通过收 / 发开关转接到通信线上,进行方向的切换,因此,会产生时间延迟.收 / 发开关实际上是由软件控制的电子开关. 
当计算机主机用串行接口连接显示终端时,在半双工方式中,输入过程和输出过程使用同一通路.有些计算机和显示终端之间采用半双工方式工作,这时,从键盘打入的字符在发送到主机的同时就被送到终端上显示出来,而不是用回送的办法,所以避免了接收过程和发送过程同时进行的情况. 

   目前多数终端和串行接口都为半双工方式提供了换向能力,也为全双工方式提供了两条独立的引脚.在实际使用时,一般并不需要通信双方同时既发送又接收,像打印机这类的单向传送设备,半双工甚至单工就能胜任,也无需倒向.

全双工模式和半双工模式在网卡中的区别 

     在全双工模式下,8根线都要分别接到水晶头相应的线序位置上;

     在半双工模式下,只需接4根线,参照T568B标准,一般使用1 、2、3、6 线序位置上的四根线,即:白橙、橙、白绿、绿 四根线;
     白橙、橙 用于发送数据 ,白绿、绿 用于接收数据。    

     全双工模式下,网线最大可以达到100兆以上的速度;
     在半双工模式下,网线能达到的速度通常为10兆左右。

     全双工模式的网线既可以工作于全双工模式,也可以工作于半双工模式;
     但半双工模式的网线不能工作于全双工模式。

     在半双工模式下,多出来的两组线可以用来接电话线,比如:把“白蓝、蓝” 这组线分出来当电话线使用。
     在局域网网络布线中,用这种方式可以节省布线成本,一根双绞线同时当网线和电话线使用。

巧用网卡的半双工模式解决网络连接故障

     如果一根全双工模式的网线内部有一根或几根线短路或接触不良,比如蓝色线组或棕色线组有问题,那么,把网卡改为半双工模式,就可以避免使用有问题的蓝色线组或棕色线组,从而解决网络连接不稳定、掉线等故障。

     在网卡属性中可以设置全双工或半双工模式。


     如上图所示,用鼠标右键单击“本地连接”,在弹出菜单中点击“属性”,进入“本地连接 属性”界面;
点击(网卡)“配置”按钮,点“高级”标签,选中“Speed & Duplex”;
     可用的模式一般有“Auto” 、“10 Mb Half” 、“10 Mb Full” 、“100 Mb Half ”、“100 Mb Full”等。
     默认设置为auto 。

     如果网络连接有问题,比如:
     不能自动获得IP地址;
     显示网络连接受限制;
     手动设置IP地址后,虽然显示网络连接正常,但是只有发送的数据包,没有收到的数据包,或者收到的数据包非常少。
     那么,修改“Speed & Duplex”的“值”为 “10 Mb Half” ,也可以改为“10 Mb Full” 、“100 Mb Half ”模式试试;
     用这种方法可以解决大部分网络连接故障。
     如果这种方法没能解决问题,就只有更换网线或水晶头,甚至更换网卡了!

     由于半双工模式下,对网速有一定影响,因此,如果网线、网卡或交换机等设备没有问题,尽量让网

RO(config)#no ip nat inside source list 1 pool dy
%Dynamic mapping in use, cannot change
RO(config)#^Z
RO#
RO#clear ip nat translation *
RO#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
RO(config)#no ip nat inside source list 1 pool dy
RO(config)#
RO(config)#

向大家推荐一个cisco模拟器GNS3,GNS3的确是个非常不错的cisco模拟器。和小凡的原理一样的,面对小凡超高的CPU利用率,你的电脑还能受得了吗,那里用GNS3吧,cpu利用率超少。
1.安装路径不要使用中文目录。安装路径最好默认,不要安装到中文文件夹里,这样会出现很多问题。
2.存放ISO文件的文件路径应为英文的,桌面也不行(桌面是中文)我就吃这方面的亏了。提示错误***Error: 209-unable to start VM instance 'R1'
3.在首选项里指定dynamips-wxp.exe的路径,并检测。不指定,有时候会提示。
4.开始路由器时,CPU使用率高,计算idle。路由器右键 idle pc 。多试几遍,最好选择带*的idle值。

用过工大瑞普的朋友,应该会用命令行,挺方便的。。

OSPF路由验证:
主要分为两大方面
1.基于链路的验证
2..基于区域的验证
这里就只发命令了,很简单。
1.基于链路的验证:
R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 1.1.1.0 0.0.0.255 area 0
R1(config-router)#network 192.168.12.0 0.0.0.255 area 0
R1(config)#interface s0/0
R1(config-if)#ip ospf authentication //接口S0/0启用简单口令认证
R1(config-if)#ip ospf authentication-key cisco //配置认证密码
或者

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 1.1.1.0 0.0.0.255 area 0
R1(config-router)#network 192.168.12.0 0.0.0.255 area 0
R1(config)#interface s0/0
R1(config-if)#ip ospf authentication message-digest//接口s0/0 启用MD5 认证
R1(config-if)#ip ospf message-digest-key 1 md5 cisco //配置key ID 及密匙
注意:加密方式,应该一样。不然无法建立关系。

2.基于区域的验证
R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 192.168.12.0 255.255.255.0 area 0
R1(config-router)#network 1.1.1.0 255.255.255.0 area 0
R1(config-router)#area 0 authentication message-digest  / /区域号0 启用MD5 认证
R1(config)#interface s0/0
R1(config-if)#ip ospf message-digest-key 1 md5 cisco   //接口配置认证key ID 及密匙 ID 1 钥匙cisco
或者
R1(config-if)#ip ospf authentication-key cisco  //接口配置认证key为cisco 明文

注意:加密方式,应该一样。不然无法建立关系。

验证优先级:OSPF 链路认证优于区域认证