2010年3月

OSPF路由验证:
主要分为两大方面
1.基于链路的验证
2..基于区域的验证
这里就只发命令了,很简单。
1.基于链路的验证:
R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 1.1.1.0 0.0.0.255 area 0
R1(config-router)#network 192.168.12.0 0.0.0.255 area 0
R1(config)#interface s0/0
R1(config-if)#ip ospf authentication //接口S0/0启用简单口令认证
R1(config-if)#ip ospf authentication-key cisco //配置认证密码
或者

R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 1.1.1.0 0.0.0.255 area 0
R1(config-router)#network 192.168.12.0 0.0.0.255 area 0
R1(config)#interface s0/0
R1(config-if)#ip ospf authentication message-digest//接口s0/0 启用MD5 认证
R1(config-if)#ip ospf message-digest-key 1 md5 cisco //配置key ID 及密匙
注意:加密方式,应该一样。不然无法建立关系。

2.基于区域的验证
R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 192.168.12.0 255.255.255.0 area 0
R1(config-router)#network 1.1.1.0 255.255.255.0 area 0
R1(config-router)#area 0 authentication message-digest  / /区域号0 启用MD5 认证
R1(config)#interface s0/0
R1(config-if)#ip ospf message-digest-key 1 md5 cisco   //接口配置认证key ID 及密匙 ID 1 钥匙cisco
或者
R1(config-if)#ip ospf authentication-key cisco  //接口配置认证key为cisco 明文

注意:加密方式,应该一样。不然无法建立关系。

验证优先级:OSPF 链路认证优于区域认证

Variance是一个乘数,取值范围是1-128之间,缺省值是1,也就是等值路径负载均衡.

使用时路由器用最小路径的度量值乘以变化因子(乘数)得出一个乘积,该乘积被用于确定一条潜在的路径是否被作为负载均衡使用

能够被选择作为负载均衡的路径必须满足两个条件:

路径的度量值必须小于当前最小度量值与变化因子的乘积;

例如:当前有如下潜在的到达同一目的地的路由,它们的度量值如下:

route1 1000

route2 1120

route3 1200

route4 1250

route5 2300

当前的变化因子:2

那么,1000*2=2000 ,所以,满足第一个条件的路由是前4条,第五条不能使用,它的度量值大于乘积

试验拓扑:

如图用eigrp配置全网络,通。
该网络本身就是非等价负载网络。
查看个路由器状态
R1#sh ip route
C    192.168.1.0/24 is directly connected, FastEthernet0/1
C    192.168.2.0/24 is directly connected, FastEthernet0/0
D    192.168.3.0/24 [90/284160] via 192.168.1.2, 00:16:03, FastEthernet0/1
R1#R1#sh ip ei topology
IP-EIGRP Topology Table for AS(1)/ID(1.1.1.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status
P 192.168.1.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0/1
P 192.168.2.0/24, 1 successors, FD is 281600
via Connected, FastEthernet0/0
P 192.168.3.0/24, 1 successors, FD is 284160
via 192.168.1.2 (284160/281600), FastEthernet0/1
via 192.168.2.2 (537600/281600), FastEthernet0/0
R2#sh ip route
C    192.168.1.0/24 is directly connected, Ethernet1/0
D    192.168.2.0/24 [90/307200] via 192.168.3.1, 00:17:19, Ethernet1/2
C    192.168.3.0/24 is directly connected, Ethernet1/2
R2#
R2#sh ip ei to
IP-EIGRP Topology Table for AS(1)/ID(2.2.2.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status
P 192.168.1.0/24, 1 successors, FD is 281600
via Connected, Ethernet1/0
P 192.168.2.0/24, 1 successors, FD is 284160
via 192.168.3.1 (307200/281600), Ethernet1/2
via 192.168.1.1 (537600/281600), Ethernet1/0, serno 31
P 192.168.3.0/24, 1 successors, FD is 281600
via Connected, Ethernet1/2
R3#sh ip route
D    192.168.1.0/24 [90/284160] via 192.168.2.1, 00:18:01, Ethernet1/0
C    192.168.2.0/24 is directly connected, Ethernet1/0
C    192.168.3.0/24 is directly connected, Ethernet1/1
R3#sh ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(192.168.3.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status
P 192.168.1.0/24, 1 successors, FD is 284160
via 192.168.2.1 (284160/28160), Ethernet1/0
via 192.168.3.2 (307200/281600), Ethernet1/1
P 192.168.2.0/24, 1 successors, FD is 281600
via Connected, Ethernet1/0
P 192.168.3.0/24, 1 successors, FD is 281600
via Connected, Ethernet1/1
就拿R3的topology来说
P 192.168.1.0/24, 1 successors, FD is 284160
via 192.168.2.1 (284160/28160), Ethernet1/0
via 192.168.3.2 (307200/281600), Ethernet1/1
根据度量值公式来算,本博客有,上一遍就是。
求入口带宽最小的,就是R3学到192.168.1.0的更新入端口。第一条线:R1的F0/1和R3的E1/0。第二条线:R1的E1/0和R3的E1/1。
我们来计算一下
首先查去以上端口的BW和延迟,只取重要的啦。
第一条线路
R1#sh inter f0/1
FastEthernet0/1 is up, line protocol is up
Hardware is AmdFE, address is c800.0d2c.0001 (bia c800.0d2c.0001)
Internet address is 192.168.1.1/24
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Half-duplex, 100Mb/s, 100BaseTX/FX
R3#sh inter e1/0
Ethernet1/0 is up, line protocol is up
Hardware is AmdP2, address is c804.0d2c.0010 (bia c804.0d2c.0010)
Internet address is 192.168.2.2/24
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
[10^7/10000+(1000+100)/10]*256=284160
第二条线路
R2#sh inter e1/0
Ethernet1/0 is up, line protocol is up
Hardware is AmdP2, address is c801.0d2c.0010 (bia c801.0d2c.0010)
Internet address is 192.168.1.2/24
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
R3#sh inter e1/1
Ethernet1/1 is up, line protocol is up
Hardware is AmdP2, address is c804.0d2c.0011 (bia c804.0d2c.0011)
Internet address is 192.168.3.1/24
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
[10^7/10000+(1000+1000)/10]*256=307200
只要要两个度量值相同,就可以形成等价负载均衡。
进入R1 接口F0/1中把延迟改为1000就可以了。
R1(config-if)#delay 100
(注意DLY的单位是usec,在配置时,改成delay 100就可以,查看就变成1000usec了,单位问题)
在不同的环境中,也可以改带宽,设置的带宽并不是物理的,bandwidth 命令只会修改 EIGRP 和 OSPF 等路由协议所用的带宽度量。今天才知道,很郁闷。
来看下路由表吧。
R3#sh ip route
D    192.168.1.0/24 [90/307200] via 192.168.3.2, 00:07:51, Ethernet1/1
[90/307200] via 192.168.2.1, 00:07:51, Ethernet1/0
C    192.168.2.0/24 is directly connected, Ethernet1/0
C    192.168.3.0/24 is directly connected, Ethernet1/1
 

EIGRP 度量值的计算公式=[ K1 * Bandwidth + (K2 * Bandwidth)/(256-Load) +
K3*Delay ]*[K5/(Reliability + K4) ] *256
默认情况下,K1 = K3 = 1 ,K2 = K4 = K5 = 0 。
Bandwidth =10^7/所经由链路中入口带宽(单位为Kbps)的最小值
Delay=所经由链路中入口的延迟之和(单位为μs)/10
也就是说默认情况下,计算公式=[10^7/Bandwidth+Delay]*256

例如:
路由条目如下。
“D 1.1.1.0 [90/20640000] via 192.168.12.1,00:04:19, Serial0/0

带宽就是Serial0/0接口的带宽。
延迟就是Serial0/0和宣告1.1.1.0网段接口的延迟。

带宽和延迟可以通过

接口的带宽和延迟可以通过“show interface ”查看

例:

R1#sh inter f0/0
FastEthernet0/0 is administratively down, line protocol is down
Hardware is AmdFE, address is c800.06fc.0000 (bia c800.06fc.0000)
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Half-duplex, 100Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog
0 input packets with dribble condition detected
0 packets output, 0 bytes, 0 underruns(0/0/0)
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

这两天被这个试验忙死了,居然钻错了方向。

NLB大致分为四个类型:1.单网卡多播

                                      2.单网卡单播

                                      3.多网卡多播

                                      4.多网卡单播

这是微软官方说的四种NLB类型。我做单播时候,虚拟机环境下没有做出来。每次重启网卡的时候就提示

Adapter Ethernet0 may not have network connectivity.MAC address 02:BF:C0:A8:05:01 of adapter Ethernet0 is within the reserved address range or is in use by another virtual adapter on your system.

一次和第二次分别down机时,可以完成冗余,在第三次切换的时候,无法连接,其他的没有问题了。不知道问题出在哪了,感觉应该是虚拟环境的问题。也没有多少技术含量。

注意一下几点:

1.使用NLB管理器的时候,应在本机把本机添加到群集中,不用在其他PC上操作本机。

2.单播群集里,不能进行通信。

3.NLB聚合后,不一定就意味着成功,自己测试一下。

在做双网卡多播时,发现一下亮点。欢迎就这样的。

都属于baidu.com域中。节点一为域控,并在上面配置DNS。节点二为域成员。

AD:192.168.5.106 255.255.255.0 DNS:192.168.5.106

         10.0.0.1 255.0.0.0 DNS:10.0.0.1

key;192.168.5.109 255.255.255.0 DNS:192.168.5.106

        10.0.0.2 255.0.0.0 DNS:10.0.0.1

测试PC:192.168.5.105 255.255.255.0 DNS:192.168.5.106

并在主机上做了WEB服务。

用域名访问没有问题。测试时,把AD的节点网卡DOWN掉,竟然能用域名访问,key的web页。我用NSLOOKUP解析,竟然解析不出来。以为是缓存的问题,把缓存清楚后,还可以。难道是key上面两卡的转换,也许就通过10.0.0.0/8网段解析的,那为什么NSLOOKUP不能解析呢,这问题就不多探讨了,当初应该把key的10.0.0.2网卡down掉,验证一下,现在也没有心思做了。

原理方面就去microsoft吧,地址奉上。

http://technet.microsoft.com/zh-cn/library/cc784785%28WS.10%29.aspx